Playing BK mod on Linux OS

Do you have a problem with the mod? Ask here for help. But read the pinned topics, so that your request can be dealt quick with.
Post Reply
Posts: 50
Joined: 22 Nov 2019, 21:47

Playing BK mod on Linux OS

Post by rappatix »

Hi! I would like to create a thread for linux users covering the hows of making the mod run on linux as there is no real guide out there. I would also like this thread to be designated to discussions related to using Blitzkrieg mod on linux. I myself together with Arqubus use linux. We both use different distributions of linux but have solved the problem of making blitzkrieg mod run the same way. This guide will also only apply to Blitzkrieg mod, even though i mention Afrika mod down below. We did the following more than a year ago so this guide might contain written mistakes, which fortunately can be corrected if someone writes so down below. :)

Here is what we did to make it run:

1. Go to steam Store and search for Company of Heores Blitzkrieg mod and subscribe to it. Now it should be available in your steam library list. Let it download and install etc.

2. Open steam, press steam in the top left corner and go to settings, there choose Steam Play in the list to the left. When done you have to "Enable Steam Play for all other titles" by checking the box that says so. You might also have to check the box to "Enable Steam Play for supported titles" if it isn't already so. I might be misremembering here.... Both boxes are at least checked for me. Also make sure that you are using the latest Proton version by pressing the arrow very close to the box for "Enable Steam Play for all other titles". There, choose the latest version of Proton.

3. Now you have to go to your library. [IT IS VERY IMPORTANT THAT YOU DO THE FOLLOWING ON THE RIGHT GAME] Right-click Company of Heroes, not Company of Heroes legacy edition, not Company of Heroes blitzkrieg mod, not one of the DLC:s. Just right-click Company of Heroes and press properties. In the general tab press "SET LAUNCH OPTIONS". Here you have to write exactly this, minus the quotation marks: "-dev -mod Blitzkrieg" and press ok. If you want to play Afrika mod (which is some kind of extension to Blitzkrieg mod) you instead write "-dev -mod Afrika" and press ok. I don't think that the "-dev" part is necessary but i use it. Try for yourself if you can start the game with or without it. For me, both combinations work.

4. Restart steam as it needs to apply the changes made by using Proton instead. Steam will not tell you to restart but I think I needed to do it to make it work... My memory again.... :P So now that you have restarted steam and done all of the above, you can start Blitzkrieg mod or Afrika mod by starting Company of Heroes, aka Vanilla. If you try to start Blitzkrieg mod by starting Company of Heroes Blitzkrieg mod in the list, steam will try to start it for a while and saying "Launching" next to the game. Soon however, the "Launching " text will disappear and nothing will happen. When starting Company of Heroes in the list, give it some time. As long as steam is saying that it's "Launching", just wait. For me it took almost 10 minutes the first time i launched it.

Now to the part that I'm not too sure about, running the beta version of the upcoming updates: Me and my fellow player Arqubus made this work by simply right-clicking Company of Heroes in steam library and enter the BETAS tab. While there, we just entered a code that can be achieved here on the forum, that enables you access to the beta version. In this case the cide were "currentBKbeta" which might change in the future, I don't know if it's always been that code or not. Anyway, enter the code, select the beta testing branch in the roll down menu when clicking on it and let the game update. This should work flawlessly. For me it didn't because I had earlier moved my installation folder to another drive on my computer and therefore messed up where the files were supposed to be or something. Anyway, the problem was solved by reinstalling the game two times and by deleting a file named "configuration.lua" that had been created during the new installs of the game. The game worked without deleting the file but had massive graphical problems.

Post Reply