Page 1 of 1

Can't load saved games.

Posted: 03 Sep 2015, 21:42
by jeepeez07
When I save a game (skirmish), I can't load it. It takes me back to the main menu. What is the problem.
Thanks for your help.

Re: Can't load saved games.

Posted: 04 Sep 2015, 10:32
by Armynator
It's working without problems for me.
Is this always the case or just for games that ran a while? How long did you played until you saved? Does it work if you save and load after just some minutes playtime?

Try running Steam and RelicCOH.exe as admin, maybe there are missing write/read permissions.

Re: Can't load saved games.

Posted: 05 Sep 2015, 11:22
by Kasbah
Never worked for me

Re: Can't load saved games.

Posted: 11 Oct 2015, 17:25
by Michael_Z_Freeman
Hi, I have this same problem with custom maps. In this mappack ... ... tles-maps/

... the copies of the maps in the official BK Map Pack save and load OK, but the other show a default loading screen. They play OK, I can save a game in Skirmish on them but loading that save just goes back to the main menu. I get this with other custom maps I have tried, such as "Desert Map Pack" (not the BK Africa one, another). I don't get the same behaviour with BK maps or Relic one's. Frustrating, as for BK Africa there are very few desert maps out there and I tend to play against the AI using saved games a lot. If this is a problem with BK maybe it can be fixed, otherwise I guess it could be old custom maps out there. If so is there a way of fixing them to allow Skirmish AI saves ?

Re: Can't load saved games.

Posted: 24 Oct 2015, 14:30
by Michael_Z_Freeman
OK, I fixed one !

Saving and loading of Skirmish games now working for the "Desert Rats" map that was included in the Africa "Desert Battle Maps" download -

Steps I used (for this map) ... OR DOWNLOAD AND SKIP TO STEP 4 IS YOU ARE A PLAYER NOT A DEV (Not sure if I have proper permissions to give this map for download, if there's a problem contact me and I will remove it).

1. Extract map using Corsix's Mod Studio ... "Load single SGA archive" --> Right click at top of archive directory tree ("data") --> "Extract all files in folder". Files *must* be extracted to top of "c:\Users\djbarney\Documents\My Games\Company of Heroes\WW2\Data\Scenarios\MP\" or WorldBuilder won't find it. I did not make a subdirectory for the map in that folder as none of the other maps had that.

2. Edited "desert" ...

Code: Select all

HeaderInfo =  
    scenarioname = "BK MOD TIP: Desert Rats (6)",
    scenariodescription = "",
    maxplayers = 6,
    date = "15.08.2012 17:20",
    scenarioabbrname = "",
    savedname = "",
    version = 2004,
    mapsize = 
    music = "",
    scenariotype = 2,
    modname = "RelicCOH",

The above is the changed version. Changed line "scenarioname =" to conform with BK naming. Changed "modname =" to "RelicCOH" mod. It was on "CheatMod".

3. Load into WorldBuilder and "Export Package" creates ""c:\Users\djbarney\Documents\My Games\Company of Heroes\WW2\scenarios\desert rats.sga" ... renamed to file name conforming to BK naming.

4. Edited "c:\Program Files (x86)\Steam\SteamApps\common\Company of Heroes Relaunch\Afrika.module" (or "Blitzkrieg.module" if you want to see the map in vanilla BK) ... Add line:

"archive.27 = Blitzkrieg\Archives\Maps\6p_Desert_Rats.sga" (without quotes) .... in ";; 6-Player Maps" section (yes, its a 6 player map).

Now map shows in Africa mod map list and saving and loading of the game it working !

Next: Loading screen needs fixing as there is one in the map archive but its not showing for some reason.

I'll try this with the other maps.

Re: Can't load saved games.

Posted: 31 Oct 2015, 06:28
by kwok
This is awesome! Thanks barney.

Re: Can't load saved games.

Posted: 07 Nov 2015, 17:38
by Michael_Z_Freeman
Here's some more ...

Hopefully these will end up in BK Africa if they have not fixed them themselves already. There are a load more desrt maps in this huge map file download - ... ?t=1803979 which I'll get to testing/fixing.