[5.0.0] - friendly AI moves all or almost all units to human player base

Do you have a bug to report? Do this right here.
winterflaw
Posts: 19
Joined: 13 Apr 2017, 12:49

[5.0.0] - friendly AI moves all or almost all units to human player base

Postby winterflaw » 29 Jul 2018, 20:00

I play single-human-player skirmish games.

It's me and some AI, vs all AI.

Quite often - at least half the time - one or more friendly AI move all or almost all units to my HQ, and they sit there, doing nothing.

If I use the attack/defend flags, they will respond and move to where those flags are, but that's no fun, because the AI just moves all or almost all units there are they sit there doing nothing.

The New BK Champion
Posts: 108
Joined: 11 Feb 2018, 22:09

Re: [5.0.0] - friendly AI moves all or almost all units to human player base

Postby The New BK Champion » 30 Jul 2018, 16:33

That might be map's fault. Some custom maps are not adjust to playing AI games. Try playing official, "overplayed maps"

User avatar
Jalis
Posts: 423
Joined: 25 Nov 2014, 04:55
Location: Canada

Re: [5.0.0] - friendly AI moves all or almost all units to human player base

Postby Jalis » 30 Jul 2018, 20:33

It sound like a confusion between two differents situations.

1) your HQ is destroyed or AI HQ is destroyed ; AI send its units around the wrecked HQ until reparation is complete.

2) After playing a certain amount of time AI spawn vehicles/Tanks but its accumulate around the spawning factories and these units do nothing.

winterflaw
Posts: 19
Joined: 13 Apr 2017, 12:49

Re: [5.0.0] - friendly AI moves all or almost all units to human player base

Postby winterflaw » 12 Aug 2018, 21:36

Jalis wrote:It sound like a confusion between two differents situations.

1) your HQ is destroyed or AI HQ is destroyed ; AI send its units around the wrecked HQ until reparation is complete.


It's not this.

I know about this, and as you say it happens after a HQ has been destroyed.

I am talking about from the beginning of the game.

2) After playing a certain amount of time AI spawn vehicles/Tanks but its accumulate around the spawning factories and these units do nothing.


I also do not mean this.

I mean from the very beginning of the game, with infantry units.
Last edited by winterflaw on 12 Aug 2018, 21:41, edited 1 time in total.

winterflaw
Posts: 19
Joined: 13 Apr 2017, 12:49

Re: [5.0.0] - friendly AI moves all or almost all units to human player base

Postby winterflaw » 12 Aug 2018, 21:39

The New BK Champion wrote:That might be map's fault. Some custom maps are not adjust to playing AI games. Try playing official, "overplayed maps"


This may be true, but I am now of the view that it is also (or perhaps only) actually an *army* problem.

I see this problem particularly with the American army.

I've been playing the Hochwaldbresche 2 map.

On either side (fixed locations) the Wehr/PE armies work correctly.

On either side, the US Armies do not work correctly.

They make a few engs, eventually make a base building or two, make lots of mortars, and keep them in their base areas. They hardly take points - sometimes starting to take, then running the eng unit back to base.

They simply do not move into the map or actually fight.

Not tried the Brits, about to.

winterflaw
Posts: 19
Joined: 13 Apr 2017, 12:49

Re: [5.0.0] - friendly AI moves all or almost all units to human player base

Postby winterflaw » 12 Aug 2018, 23:07

Brit army seems okay.

User avatar
Panzerblitz1
Team Member
Posts: 1514
Joined: 24 Nov 2014, 00:12
Location: Paris, right under the Eiffel tower.

Re: [5.0.0] - friendly AI moves all or almost all units to human player base

Postby Panzerblitz1 » 13 Aug 2018, 15:59

Very weird, you might have another mod or something wrong with your files...
Image

User avatar
Jalis
Posts: 423
Joined: 25 Nov 2014, 04:55
Location: Canada

Re: [5.0.0] - friendly AI moves all or almost all units to human player base

Postby Jalis » 14 Aug 2018, 05:05

It is an unknow problem from me, sorry, I cant help.

winterflaw
Posts: 19
Joined: 13 Apr 2017, 12:49

Re: [5.0.0] - friendly AI moves all or almost all units to human player base

Postby winterflaw » 15 Aug 2018, 16:16

Panzerblitz1 wrote:Very weird, you might have another mod or something wrong with your files...


No other mods.

I am sure something is amiss with my install, because the start screen is messed up.

I'm hoping the next release fixes it, otherwise I may have to reinstall from scratch.

However, it seems odd this would break just one army.


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 2 guests