Missing Unit Icons

Do you have a problem with the mod? Ask here for help. But read the pinned topics, so that your request can be dealt quick with.
User avatar
PanzerDillane
Posts: 7
Joined: 13 Apr 2016, 00:00
Location: Republic Of Ireland

Missing Unit Icons

Postby PanzerDillane » 13 Apr 2016, 00:04

Hey guys, I've been playing Blitzkrieg mod for the better part of two years now and have never had a problem until now. I just re installed blitzkrieg mod with the latest 2016 patch as well as the map pack and the historical mod. However, in game there are missing unit/building icons. This applies to all factions although the Americans are missing most of them including the infantry doctrine menu picture. All my settings are on medium and i've reinstalled numerous times to no avail Any suggestions? TIA :roll:

User avatar
Wolf
Administrator
Posts: 983
Joined: 23 Nov 2014, 16:01
Location: Czech Republic

Re: Missing Unit Icons

Postby Wolf » 13 Apr 2016, 00:11

Hey, have you tried without historical mod?
I'd recommend to just uninstall everything BK related.
Try vanilla coh - test it ingame
Then install 4.8.6 Full - test it ingame
Install 4.9.5 Patch - test it ingame
Install mappack - test it ingame
etc.
Image

User avatar
Tiger1996
Posts: 3796
Joined: 06 Dec 2014, 15:53
Location: I'm from Egypt, but I live in Qatar.
Contact:

Re: Missing Unit Icons

Postby Tiger1996 » 13 Apr 2016, 00:56

What's ur maximum screen resolution? What's ur VGA?? If it's Nvidia, u will then pretty much need a resolution of 1920x1080 (full HD) in order to have it running correctly with the historical addon v2 without any problems... Missing icons are mainly due to the resolution based on ur graphics card or because of an old DirectX version.

User avatar
PanzerDillane
Posts: 7
Joined: 13 Apr 2016, 00:00
Location: Republic Of Ireland

Re: Missing Unit Icons

Postby PanzerDillane » 13 Apr 2016, 01:20

Hey Wolf, I've tried with loads of different mods and the stock coh and it works perfectly every time it's just BK Mod that won't load the icons properly. It's only in the last 2 months that I lose all the icons in BK Mod.

Tiger1996: I'm not very tech savy tell me how I can figure all this out and i'll get the information :)

User avatar
Tiger1996
Posts: 3796
Joined: 06 Dec 2014, 15:53
Location: I'm from Egypt, but I live in Qatar.
Contact:

Re: Missing Unit Icons

Postby Tiger1996 » 13 Apr 2016, 01:25

No problem, that's fine.. but I only need to know about ur screen resolution... 1440x900? Or 1366x768?? Or maybe 1280x720??? What exactly?!

User avatar
PanzerDillane
Posts: 7
Joined: 13 Apr 2016, 00:00
Location: Republic Of Ireland

Re: Missing Unit Icons

Postby PanzerDillane » 13 Apr 2016, 01:53

Well playing the game it's actually 800x600 I never changed it. Should I up it and see?

User avatar
Wolf
Administrator
Posts: 983
Joined: 23 Nov 2014, 16:01
Location: Czech Republic

Re: Missing Unit Icons

Postby Wolf » 13 Apr 2016, 02:11

Again, try it with 4.8.6 first, then try with patch etc.
Image

User avatar
PanzerDillane
Posts: 7
Joined: 13 Apr 2016, 00:00
Location: Republic Of Ireland

Re: Missing Unit Icons

Postby PanzerDillane » 13 Apr 2016, 02:15

I've been playing with 4.8.6 for the last 6 months and I've always had 1 or 2 missing icons but now the majority of them are missing. It doesn't help patching and tbh that seems to make it worse.

User avatar
Jagdpanther
Posts: 226
Joined: 15 Dec 2014, 03:33

Re: Missing Unit Icons

Postby Jagdpanther » 13 Apr 2016, 03:04

it's the resolution, 800x600 is 90's res

User avatar
PanzerDillane
Posts: 7
Joined: 13 Apr 2016, 00:00
Location: Republic Of Ireland

Re: Missing Unit Icons

Postby PanzerDillane » 13 Apr 2016, 04:56

Gents thanks very much it was indeed a problem with the resolution. Thanks guys the game is once again enjoyable :)

User avatar
XAHTEP39
Posts: 210
Joined: 09 May 2015, 12:34
Location: Saint-Peterburg, Russia

Re: Missing Unit Icons

Postby XAHTEP39 » 13 Apr 2016, 10:55

Tiger1996 wrote:What's ur maximum screen resolution? What's ur VGA?? If it's Nvidia, u will then pretty much need a resolution of 1920x1080 (full HD) in order to have it running correctly with the historical addon v2 without any problems... Missing icons are mainly due to the resolution based on ur graphics card or because of an old DirectX version.

Hmmm, yes I have some misiing icons in HistAddon (for example: Sabotage squad in call-in menu)... But I have only notebook with max 1366x768 resolution in game options :cry: What should I do? :roll:

User avatar
Tiger1996
Posts: 3796
Joined: 06 Dec 2014, 15:53
Location: I'm from Egypt, but I live in Qatar.
Contact:

Re: Missing Unit Icons

Postby Tiger1996 » 13 Apr 2016, 13:38

I also have a laptop with maximum screen resolution of 1366x768, and I have encountered lots of disappearing icon problems with the historical addon v2 as well specifically while running my game on an Nvidia VGA. But luckily my laptop has 2 VGAs and not only a single one ^^ A higher performance Nvidia and a lower performance Intel integerated VGA too. I tried everything possible in order to try fixing the icons issue with the Nvidia but simply it never worked.. as it highly depends on ur screen resolution based on the graphics card together with the DirectX version ur VGA is using. I figured out that apparently there is noway possible at all to fix it for the Nvidia which uses DirectX 11 unless if I have a resolution of 1920x1080 of which I don't.. just like u.

What I did was to switch my CoH to run on the lower performance Intel VGA which uses DirectX 10. The icons therefore worked fine at 1366x768!! But of course at the cost of less FPS compared to the Nvidia.. since that the Intel is a lower performance VGA.

If u don't have an Intel VGA beside ur Nvidia in ur laptop.. then I am afraid there is nothing to do except to have a new external full HD screen with a resolution of 1920x1080 to be attached with ur laptop! Or to force ur Nvidia to work on DirectX 10 of which is something I really don't know how exactly it could be ever done as it might be risky as well.


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest